or Login >>         
C4 - DS4 Owners :: Forums :: Coupe and Hatch Pre 2011 cars :: C4 The Garage

Oil Level indicator

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
spligosh   
Mon Jun 04 2007, 10:49am
Hi everyone.

Recent owner of my first C4 1.6 HDI Coupe. (wicked Red)

Very happy with it so far - so much better than the C3 I previously owned.

It's just been back in for its post-delivery inspection and when it came back the oil level indicator lights weren't displaying.

The little vertical bar at the top is lit but the rest of the lines aren't.

Anyone come across this before?
Rich_Eason   
Mon Jun 04 2007, 11:08am

Member No: #90
Joined: Jan 29 2007
Location: Bristol
Welcome to the forum!

You will only notice your oil level indicator when you put the key in the ignition and turn the key to start. The level will flash on the temp guage (think three blobs = max level) and "OIL OK" will illuminate. This will then go out and revert to engine temp.

If the oil level is too low you will get a warning on the display HOWEVER....this does not excuse you going out to the bonnet with a rag and checking every week along with your tyres

Most oil lights only operate when things have gone beyond critical and heading for melt down...i.e.no oil.

I have experienced a couple of times with the car on a steep hill the warning cropping up where the level of oil has gone above/below the sensor and thus confusing it. This reverts to normal on moving and turning off the engine.

Hope this helps
spligosh   
Mon Jun 04 2007, 04:14pm
Thanks Rich

I should have thought before I posted - I feel proper stupid now :$

You are quite right - and it was exactly the same on my C3 !!

I was looking at the temperature gauge and thinking it was the oil level - Doh!

Thanks for the quick response anyway
l.a.leisure   
Sat Aug 04 2012, 06:00pm
Hi, new to this.
Just tagging on to what you were talking about.
I had my engine oil level indicator come on too, it was parked on a flat road and when i went to start it, it came up (check engine oil level. Yes it needed topping up, but even after topping up, The check oil level still comes up. The car isn't due a service for another 9,000 miles, so i don't need to change the filter yet.
So what would cause this to happen.
Dave_Retired.   
Sun Aug 05 2012, 01:14am

Member No: #1
Joined: Aug 07 2006
Location: Northumberland
Faulty sensor, it's not uncommon and the next thing to check after the filter.

However, the 'oil level check' light comes on every time you start the car as part of the startup process.

If the light goes out, then everything is fine, that's quite normal behaviour.
1 User said Thank You to Dave_Retired. for this Post :
  (05 Aug 2012 : 03:31)
bagi.chat   
Thu Oct 24 2019, 01:05pm
Member No: #54891
Joined: Oct 24 2019
Location: Amsterdam
Hi there,

Piggybacking on this topic. I do have a slightly different issue where the actual oil level result is not showing up. Getting the "oil _ _ " blink and disappears. So nothing stating that its okay or what is the actual leve. Anyone experienced this? Any tips suggestions?

I've added the video on how it looks like:
https://imgur.com/cYE2FSU
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member