or Login >>         
C4 - DS4 Owners :: Forums :: C4 Picasso and Grand Picasso - PRE 2013 only :: C4 Picasso and Grand Picasso General questions

All warning light come on when ignition starts

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
scaryxpuppy   
Sat Oct 01 2022, 03:53pm
Member No: #53791
Joined: May 25 2019
Location: Stratford upon Avon
My 2013 C4 Picasso has suddenly developed a problem where ALL the warning messages seem to come one after another when starting the ignition.

Errors such as “parking brake issues”, “roll back”, “Driving aids”, “ABS” etc etc etc, all accompanied with the annoying beep.

The car runs absolutely fine, and no warning messages have ever come up before, so am wondering if this could be an electrical short fault or something similair with the ECU but am wondering if anyone else has encountered a similar problem.

The only thing I can think is maybe the battery might be at fault and not providing enough to the ECU but haven’t had a chance to test yet.

All help or advice gladly received

Phil


gittos   
Sat Oct 01 2022, 05:17pm
Member No: #30055
Joined: Apr 02 2013
Location: Bolton
Good chance it’s the battery.
1 User said Thank You to gittos for this Post :
 scaryxpuppy (02 Oct 2022 : 04:27)
scaryxpuppy   
Sun Oct 02 2022, 04:29am
Member No: #53791
Joined: May 25 2019
Location: Stratford upon Avon
Yep. Will check the battery when I get back home. The errors seem to come on even before firing up, just with the simple START press. Would it be more likely to be the battery if problems started when actually firing? Really not that sure and thanks again. P.
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member