or Login >>         
C4 - DS4 Owners :: Forums :: C4 Picasso and Grand Picasso - PRE 2013 only :: C4 Picasso Problems and issues

Boot microswitch.

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
Suffolk   
Fri Aug 05 2022, 01:23pm
Member No: #30199
Joined: Apr 10 2013
Location: Brandon Suffolk
I realise this has been discussed and I half solved my issue after reading, the button was clicking but not releasing I tried a little packing to no avail so purchased an aftermarket switch. in the meantime I left the push on connector with a loop of florist wire in one side and just completed the loop bu pushing into the opposite terminal when I needed access. New switch arrives, check the working of by justing plugin in and all works, push the handle back into the recess. Didnt bother checking ' Der' take OH shopping and it doesn't work, fortunately have the thin screwdriver in boot so flick release and load up leaving space for same when we get home. pop the handle out and as soon as its released from the socket the release works and every time you press, L, R or centre. push back in fails. pop it out to see if theres any bare wire causing a short and cannot see anything. Any suggestions please. OH and for info here's a pic of the old switch you can see why it failed the solder ring is not complete. check avatar, couldnt work out how to get image up.



routemaster1   
Fri Aug 05 2022, 01:53pm
Member No: #574
Joined: Jul 08 2007
Location: Dorset
You cannot post pictures unless you are a Premier member. You can upload photos and videos to hosting sites like Flickr and Youtube and post a link.
1 User said Thank You to routemaster1 for this Post :
 Suffolk (06 Aug 2022 : 13:52)
vexorg   
Sat Aug 06 2022, 03:01am
Member No: #48843
Joined: Jul 06 2017
Location: Scotland
The c4 boot switch should be a straight swap with the ebay type
Suffolk   
Sat Aug 06 2022, 01:53pm
Member No: #30199
Joined: Apr 10 2013
Location: Brandon Suffolk
routemaster1 wrote ...

You cannot post pictures unless you are a Premier member. You can upload photos and videos to hosting sites like Flickr and Youtube and post a link.


Thanks for the info, I managed to post the pic as my avatar, for no reason other than info for others.
Suffolk   
Sat Aug 06 2022, 01:55pm
Member No: #30199
Joined: Apr 10 2013
Location: Brandon Suffolk
vexorg wrote ...

The c4 boot switch should be a straight swap with the ebay type


did a straight swap with an eBay one, works when hanging freely then you push it home and it doesn't trigger which suggested a short or trapped wire ??
Suffolk   
Fri Sep 09 2022, 06:23am
Member No: #30199
Joined: Apr 10 2013
Location: Brandon Suffolk
got a fix and thought it would be useful to post.

The newly purchased part , handle and switch plugs into the wiring inside the boot skins. I had tried a piece of florist wire from + to - and the catch released every time, plugged in handle etc and it worked when pushing into the recess and closing the boot no joy.
I removed the plug and put a single piece of said florist wire ( maybe 5 amp fuse size ) into each hole refitted the handle and it has been working ever since. A local auto electrician said maybe a little damp had caused the connections to fail, I couldn't see a way to clean either the pins or the socket so ive left as is.
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member