or Login >>         
C4 - DS4 Owners :: Forums :: C4 Picasso and Grand Picasso - PRE 2013 only :: C4 Picasso and Grand Picasso General questions

Heater Blower won't stop!

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
Carpathian7   
Mon Jul 20 2020, 12:19pm
Member No: #55809
Joined: Mar 14 2020
Location: Barnsley
2010 C4GP 1.6tdi. Had the usual problems with the blower not working at all. Drained the water out, some improvement, fan would work on low settings but if you turned it up it would blow for a couple of seconds, then stop, start again etc. So I fitted a new resistor pack, and all was fine for a while. Worked on all settings, demister fine, air con cold and heater warm and toasty. Turned the ignition on a couple of days ago and the blower was going full blast. Turned the fan up and down, no difference.

I've read through lots of posts on the forum, but only found one similar, and there were no answers, so I thought I'd have a go. My only guess is the resistor pack isn't resisting anymore. Has anyone got resistances between the terminals so I could check mine?

Carpathian7   
Sat Sep 19 2020, 07:03pm
Member No: #55809
Joined: Mar 14 2020
Location: Barnsley
Well thanks for all the help! Bought another resistor pack and it's working fine.
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member