or Login >>         
C4 - DS4 Owners :: Forums :: C4 Picasso and Grand Picasso - PRE 2013 only :: C4 Picasso Problems and issues

Lift joint rusty/broken

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
GrandZen   
Mon Mar 30 2020, 09:06am
Member No: #55865
Joined: Mar 30 2020
Location: Sweden
Hi.

After changing the front suspension i got errors on the back so i changed pneumatic airbags but i'm not sure the car is fully adjusted to the new height. First when i got back from repairshop it let go of a lot of air. Then didn't fill any when we drive which was a scary drive for sure. Even after we did a small stop it didn't inflate until we got home and finaly parked. I tried the BSI reset but no idea if that actualy help. I would pump manualy from the trunk but apparently the lift under are both rusty and broke off. I don't know how to find the joint or if i can replace it without going broke?

- Click Here -
- Click Here -
Edit: it's the small arm on the height level sensor thats broken. I don't know if that alone is enough to cause the issues with height. Temporary welded at repairshop. Will see how long that lasts. Still letting out all air when parked which i guess is an issue for the compressor. I haven't had any big testrun yet so i don't know if it change height during drive. Maybe my back suspension is done for?
[Admin edit]Links sorted[/Admin edit]
neilp   
Mon Mar 30 2020, 10:34am
Member No: #3384
Joined: Apr 21 2008
Location: Bulwell, Nottingham
Don't have an answer but both your links report an error when I try them.
GrandZen   
Mon Mar 30 2020, 10:42am
Member No: #55865
Joined: Mar 30 2020
Location: Sweden
See if these work better.

- Click Here -
- Click Here -
GrandZen   
Wed Apr 29 2020, 11:44am
Member No: #55865
Joined: Mar 30 2020
Location: Sweden
I got it welded and works but now I got another issue. I changed airbags before I noticed the broken sensor and it's leaking. They are cheap I guess but new. Is there any way of checking for leaks and fixing them? Spray the tire foam into it if it's a small leak?
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member