or Login >>         
C4 - DS4 Owners :: Forums :: Coupe and Hatch Pre 2011 cars :: C4 Coupe and Hatch (pre 2011) Problems?

ABS/ESP failure (need to pass MOT)

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
JoeyBuddy   
Wed Aug 14 2019, 05:06am
Member No: #54417
Joined: Aug 14 2019
Location: Watford
Hi guys,

I know there's quite a few threads on abs issues but I'd still like to post my exact symptoms in the hope of being able to fix it. The garage currently has the car for the MOT and are trying to figure out this problem.

I have 2009 C4 110 HDI hatchback whcih I bought a hear ago. When I bought it the guy said the ABS/ ESP light comes on, but that it was an electrical fault and they couldn't figure out how to solve it. The breakers have always seemed fine to me.

Basically the light always comes on after I drive the car faster than a few MPH/more than a few seconds. There was a period of time when fuel bar got so low that it had the 'no fuel' warning, and when I filled it up the ABS error went away for several months.

It has since come back for the last few months or so. I am wondering if anyone has good advice on what might be causing my particular fault.

Help very much appreciated. I'm in a tricky spot as I've just moved to UK and I need the car cleared ASAP!
rusky   
Wed Aug 14 2019, 06:28am
Member No: #27768
Joined: Oct 13 2012
Location: Hove
You need to get the fault codes read. That'll tell you where to start looking.
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member