or Login >>         
C4 - DS4 Owners :: Forums :: C4 Picasso and Grand Picasso - PRE 2013 only :: C4 Picasso Problems and issues

EGS gearbox fault

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
stephen.williams   
Wed Aug 14 2019, 05:04am
Member No: #53796
Joined: May 26 2019
Location: Cheterfield
Hi all

I own a 2012 C4 diesel EGS (VTR+ I think) that has done 40k miles. I started the car on Monday, put it in reverse, there was a loud clunk, the engine stopped immediately, and the warning "gearbox fault" appeared. Now, when I try to start the car, the message " economy mode" appears, and the car will not start (presumably because it is in reverse gear).

Recently, there has been a slight but noticeable knocking when the car engaged / disengaged the clutch from a stand still. The car also does seem to slip the clutch a bit more than necessary when changing gear but this could be normal.

Any ideas what the fault might be given this information.

The car is being towed to my local independent garage this weekend. He is not a specialized Citreon repair shop. I thought some upfront research might help him repair the fault and keep the repair costs down.

Many thanks for any help.
rusky   
Wed Aug 14 2019, 06:29am
Member No: #27768
Joined: Oct 13 2012
Location: Hove
Could be low actuator fluid.

Economy mode is just to stop the battery draining to the point where the engine can't be started.
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member