or Login >>         
C4 - DS4 Owners :: Forums :: C4 Picasso and Grand Picasso - PRE 2013 only :: C4 Picasso Problems and issues

Help

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
Gtranter1976   
Sat Aug 10 2019, 01:17pm
Member No: #54394
Joined: Aug 10 2019
Location: Dudley
Hi I own a c4 grand Picasso 09 petrol the abs/ esp and parking brake fault light have come on I read the codes with diagbox the code pointed to the clutch switch which I replaced I had the same fault 9 months ago and the switch was also replaced then and the problem went away this time though replaced the switch and the light is still on plus additional codes
U13A1
U1208
P1711
On my car there is also another switch at the back of the clutch pedal and there is a small rod attached to it that sits on the top left of the clutch pedal and as you push the pedal it moves the switch on and out I have spoke to Citroen and they say there is no such part on my car and there is only one sensor on my car which is the clutch control switch which has been replaced any help is much appreciated
Gtranter1976   
Sun Aug 11 2019, 06:49am
Member No: #54394
Joined: Aug 10 2019
Location: Dudley
I have changed the clutch switch again and its fine now must of been a faulty switch if anyone has a similar problem maybe check the switch is not faulty
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member