or Login >>         
C4 - DS4 Owners :: Forums :: Coupe and Hatch Pre 2011 cars :: C4 Coupe and Hatch (pre 2011) Problems?

Beeps and idle

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
Dalealan   
Thu Jun 13 2019, 05:19am
Member No: #53926
Joined: Jun 13 2019
Location: Sunderland
Hiyas and I hope I'm posting this in the right place. Well I've jumped back onto the Citroen train following on from a love affair with Saxo VTS's in my younger years but I seem to be having a couple of minor niggles with the C4. When I first start it there's a series of 8 rapid beeps after about 5 seconds? No biggie I suppose but I can't seem to find out what they mean. No warning lights or anything untoward flashing up just trying to track down if this is normal. Also it drives fine but seems to hesitate when idling once every couple of seconds. Not enough to stall just a slight judder from the engine as if it's slightly missing or the timing is out as you can see the engine move a little when it happens. I'm thinking it may be coilpack / sparkplugs or similar or maybe the timing being out as he had the belt changed a bit ago as it was my neighbours car (went through a few coilpacks in my saxo days but this seems very slight) or it could be completely normal but any advice would be hugely appreciated. Thanks for any advice.
neilp   
Thu Jun 13 2019, 08:42am
Member No: #3384
Joined: Apr 21 2008
Location: Bulwell, Nottingham
It shouldn't beep when you start up.
Slight hesitation could be plugs I suppose.
Which engine is it 1.4 or 1.6, I think the 1.4 had a bit of a problem with head gaskets, so that's a possibility if it's a 1.4.
1 User said Thank You to neilp for this Post :
 Dalealan (13 Jun 2019 : 09:05)
Dalealan   
Thu Jun 13 2019, 09:02am
Member No: #53926
Joined: Jun 13 2019
Location: Sunderland
neilp wrote ...

It shouldn't beep when you start up.
Slight hesitation could be plugs I suppose.
Which engine is it 1.4 or 1.6, I think the 1.4 had a bit of a problem with head gaskets, so that's a possibility if it's a 1.4.


Thank you so much for the reply. Damnit I knew I'd left something off. It's the 1.6 petrol VTR+. Runs really smoothly when driving just the slight judder when idle which can be felt through the pedals and can be heard and seen on the engine. Might give it a full service just to see if it eases it off. Yip I'm definitely clutching at straws Still can't work the beeps out as there's a beepbeepbeepbeep when starting the engine then nothing else. Can't seem to find anything in the handbooks or on the internet what mentions it. Curiouser and curiouser but it's no biggie I suppose unless it means somethings kaputted.
rusky   
Fri Jun 14 2019, 10:51am
Member No: #27768
Joined: Oct 13 2012
Location: Hove
Have you asked your neighbour?

Anyone know does an uncoded radio do this or does it beep continuously?
1 User said Thank You to rusky for this Post :
 Dalealan (14 Jun 2019 : 10:58)
Dalealan   
Fri Jun 14 2019, 11:07am
Member No: #53926
Joined: Jun 13 2019
Location: Sunderland
rusky wrote ...

Have you asked your neighbour?

Anyone know does an uncoded radio do this or does it beep continuously?


Thank you for the reply. Yes asked him but hes an older gentleman so wasn't the best of help as he wouldn't notice if the bumper fell off . Hmmm could be the radio if it's had a replacement fitted but it looks original but mightnt be matched to the vin but im not sure if the sound would come through the speakers as opposed to coming from the dash area?? I still can't find what the beeps mean. Tinternet has let me down. Could be a trip to someone with lexia just to see if it's anything to worry about. Going to clean the throttle body and maybe the maf to see if it cures the slight judder but it seems to have eased off slightly after giving it a good hoof about last night so something might need a good going over with some cleaner. The search continues .....
Edit: think you’ve got the nail on the head with the radio as it mutes it when the beeps start. Doesn’t make any difference if it’s on or off when I start the car but yeah I think you’ve nailed it. Huge thanks.
neilp   
Sat Jun 15 2019, 02:59am
Member No: #3384
Joined: Apr 21 2008
Location: Bulwell, Nottingham
From what I've read on here in the past an un-coded radio would beep every so often and not just at start.
Your neighbour should know if the radio has been changed though I would have thought.

edit: the service might need a new air filter.
1 User said Thank You to neilp for this Post :
 Dalealan (15 Jun 2019 : 03:30)
Dalealan   
Sat Jun 15 2019, 03:30am
Member No: #53926
Joined: Jun 13 2019
Location: Sunderland
neilp wrote ...

From what I've read on here in the past an un-coded radio would beep every so often and not just at start.
Your neighbour should know if the radio has been changed though I would have thought.

edit: the service might need a new air filter.


Nope just the series of around 8 rapid beeps when I first start the car but no others when driving. He bought it second hand so it could well have been changed from a previous owner . I’ve ordered the filters and stuff and I’ve just YouTubed how to change the air filter. So I basically dismantle the car to get to the back two screws? At least it’ll keep me out of mischief for a bit

I’m now thinking maybe one of the lambda sensors may need changing after reading the sticky on here as it points to an erratic idle but I thought it may have chucked the eml light on but it might just be a bit off? There does seem to be a slight hesitation when it hits 4K revs in all gears now. I’ll book it in somewhere to get a diagnostic or see if I can get a laptop with xp on and buy a lexia. Oh the fun of cars
neilp   
Sat Jun 15 2019, 10:31am
Member No: #3384
Joined: Apr 21 2008
Location: Bulwell, Nottingham
You can download the routine for removing the air filter box here
- Click Here -

Or read a thread with detail here
- Click Here -

Done it twice on my old car and easy once you know how.

Edit: to eliminate the radio beeps you could take it out/disconnect it and see if it still beeps.
1 User said Thank You to neilp for this Post :
 Dalealan (15 Jun 2019 : 10:56)
rusky   
Sat Jun 15 2019, 10:33am
Member No: #27768
Joined: Oct 13 2012
Location: Hove
I have a complete diagbox setup for sale, no laptop though.
1 User said Thank You to rusky for this Post :
 Dalealan (15 Jun 2019 : 11:00)
Dalealan   
Sat Jun 15 2019, 10:58am
Member No: #53926
Joined: Jun 13 2019
Location: Sunderland
neilp wrote ...

You can download the routine for removing the air filter box here
- Click Here -

Or read a thread with detail here
- Click Here -

Done it twice on my old car and easy once you know how.

Edit: to eliminate the radio beeps you could take it out/disconnect it and see if it still beeps.


Good idea on the radio I’ll stick it on the to do list which is getting longer by the day that’s much appreciated. Seems a lot easier in the pics than in the YouTube video I watched as he was unbolting lots of stuff and I think he was swearing a lot in Polish hah
Dalealan   
Sat Jun 15 2019, 11:00am
Member No: #53926
Joined: Jun 13 2019
Location: Sunderland
rusky wrote ...

I have a complete diagbox setup for sale, no laptop though.



Thank you for the offer but if it doesn’t start behaving itself I’ll be driving it back through my neighbours wall. Grrrrr
Dalealan   
Sun Jun 16 2019, 06:00am
Member No: #53926
Joined: Jun 13 2019
Location: Sunderland
Well after spending 10 minutes looking for where the maf sensor is I’ve came to the conclusion that the petrols don’t have them so that’s a morning well spent hah on a different note though I’ve found this hanging down behind the ashtray which is slightly confusing. Time to yank the dash out and see where it’s coming from.

- Click Here -
lasiakutevs   
Mon Jun 17 2019, 04:16am
Member No: #52509
Joined: Nov 12 2018
Location: Joniškis
i think the cable is from a parrot hands free kit screen have one in my c4
1 User said Thank You to lasiakutevs for this Post :
 Dalealan (17 Jun 2019 : 05:48)
lasiakutevs   
Mon Jun 17 2019, 04:19am
Member No: #52509
Joined: Nov 12 2018
Location: Joniškis
if the screen is not connected to the parrot system it starts to beep to let you know that its turned on
1 User said Thank You to lasiakutevs for this Post :
 Dalealan (17 Jun 2019 : 05:48)
Dalealan   
Mon Jun 17 2019, 05:47am
Member No: #53926
Joined: Jun 13 2019
Location: Sunderland
lasiakutevs wrote ...

if the screen is not connected to the parrot system it starts to beep to let you know that its turned on


Woohoo that may be the cause of the 8 rapid beeps on startup. If the wiring is there I could be tempted to get a screen as one of the previous owners must have removed it and they seem a handy bit of kit. Huge thanks for the reply.
Go to page       >>   

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member