or Login >>         
C4 - DS4 Owners :: Forums :: C4 Picasso and Grand Picasso - PRE 2013 only :: C4 Picasso and Grand Picasso General questions

Rear Wiper arm not moving but motor working!!

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
Simon24wrx   
Sun Oct 14 2018, 10:41pm
Member No: #50555
Joined: Feb 23 2018
Location: Oxfordshire
Hi

Hopefully someone can assist me!! My rear wiper isn’t moving but I’m checking the motor is working fine - is there a way that the wiper arm pin doesn’t fit into the black circle of the Motor unit.

Didn’t know if this is a common fault - I’ve tried everything - but concerned that I’ll break the rear windscreen soon!!

Thanks

routemaster1   
Mon Oct 15 2018, 01:56am
Member No: #574
Joined: Jul 08 2007
Location: Dorset
Is yours an Exclusive with an opening tailgate window? If it is it is possible to misalign when closing the window
Simon24wrx   
Mon Oct 15 2018, 06:02am
Member No: #50555
Joined: Feb 23 2018
Location: Oxfordshire
It’s an exclusive - the top window opens but can’t seem to align it - wondered if I’m missing something.

Will WD40 all the parts later - the motor works as I can open the window part and click the latch to trick it that the window is closed and the mechanism moves fine
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member