or Login >>         
C4 - DS4 Owners :: Forums :: C4 2011 (B7) DS4 and DS4 CROSSBACK :: Road Tests and Reports

C4GP 1.6hdi diesel won't start!

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
nathan251145   
Fri Jul 20 2018, 05:59pm
Member No: #46755
Joined: Nov 12 2016
Location: UK
Hi All, my c4gp was becoming noisy due to fuel injector seal worn off. So I replaced the seal and put everything back as before. Now I try to start the engine, but it won't start. Anybody knows if there is anything required to be done before starting the engine.
I tried to prime the fuel but it did not help
Any help will be appreciated.
Thanks in advance
Nathan
Magistrate   
Sat Jul 21 2018, 12:03am
Member No: #1731
Joined: Dec 15 2007
Location: Walsall West Midlands
More than one seal replaced? As each is coded to the cylinder they need replacing in the exact same place as they were taken.
nathan251145   
Sat Jul 21 2018, 12:57am
Member No: #46755
Joined: Nov 12 2016
Location: UK
Thanks for the response. Only one seal was replaced. Nothing else was done except putting a new seal. The fuel pipe, top line and the electric connector was removed from the injector and then put back exactly as they were before.
Is anything required to be done after putting all back before starting the engine?
nathan251145   
Sun Jul 22 2018, 06:04am
Member No: #46755
Joined: Nov 12 2016
Location: UK
After refitting the fuel injector, when I try to start the engine, the engine cranks but does not start. Please help. What am I missing. Why won't it fire up.
Any help will be appreciated
Thanks
Nathan
rusky   
Sun Jul 22 2018, 08:33am
Member No: #27768
Joined: Oct 13 2012
Location: Hove
You need to see if there are any fault codes stored.
nathan251145   
Mon Jul 23 2018, 09:07am
Member No: #46755
Joined: Nov 12 2016
Location: UK
Thanks for responding. Here is the update..
The fault recorded was P1351.
So I removed the top part of the fuel injector and noticed that a spring/coil was missing. I found it lying around. I put it in the top section and put it all back. Good news- the engine is now starting! But bad news- it is rattling a lot and making a tuk tuk sound. There is also smell of fumes. May me the injector is not firing.
Looks like I did something wrong. Can someone advice what may be the problem please
Thanks in advance
Nathan
riven1962   
Mon Jul 23 2018, 09:28am
Member No: #18905
Joined: Mar 23 2011
Location: Widnes, Cheshire
That tuk tuk sound will be a loose injector seat. That's why you are also getting some fumes.
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member