or Login >>         
C4 - DS4 Owners :: Forums :: C4 Picasso and Grand Picasso - PRE 2013 only :: C4 Picasso Problems and issues

Faulty parking brake and engine hot , new owner please help.

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
Hayzc4   
Fri Jul 13 2018, 04:21am
Member No: #51619
Joined: Jul 12 2018
Location: Bristol
Hi guys, I'm new to this forum and new to owning a c4 Picasso.
I've had the car a week and yesterday when I started the car I had " faulty parking brake" come on the dash, I turned the engine off and back on again which the car then started with no problems. But then on the evening, it came up again so did the same but when started the fault come up again, so the ed it off one more time and this time I heard like a clunk coming from the back of the car, it started up with no faults, however this morning I had " parking brake faulty" and " engine to hot, stop"
Any clues why this is happening? I've looked at a few posts and people say might be the battery. Cheers Haley
rusky   
Fri Jul 13 2018, 12:29pm
Member No: #27768
Joined: Oct 13 2012
Location: Hove
You need to get the fault codes read, it could be a few things. Battery, brake switch, brake pedal switch...
Hayzc4   
Fri Jul 13 2018, 12:49pm
Member No: #51619
Joined: Jul 12 2018
Location: Bristol
It's booked in tomorrow to be plugged in, I'm hoping it's nothing to bad.
Il be a nervous wreck waiting for the call
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member