or Login >>         
C4 - DS4 Owners :: Forums :: Coupe and Hatch Pre 2011 cars :: C4 The Garage

2014 C4 Picasso ECO OFF and Sevice light on all the time

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
Nigel7   
Wed May 16 2018, 02:17pm
Member No: #49212
Joined: Aug 20 2017
Location: Danbury, Essex
My C4 Picasso has developed a fault the ECO stop start system has stopped working and Service light on. I took my car to my local Citroen dealer with the above fault. To cut a long story short, they did lots of tests and checks even repairing two broken wires. Apparently it had a lot of strange codes that they couldn’t understand, they spoke to Citroen technical who suggested changing the capacitor and control unit costing over £900 in parts alone. But they couldn’t guarantee that it would cure the fault ! Has anybody had this problem and found a cure
rusky   
Wed May 16 2018, 04:05pm
Member No: #27768
Joined: Oct 13 2012
Location: Hove
You do realise you posted this in the wrong forum?

It could be as simple as a failing battery. It might be worth taking it to Halfords/ATS/Kwikfit etc. to get it tested if the Citroen dealer didn't test it.

What's your usage like with the car? short journeys or long?
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member