or Login >>         
C4 - DS4 Owners :: Forums :: Coupe and Hatch Pre 2011 cars :: C4 Coupe and Hatch (pre 2011) Problems?

Ran over debris on motorway...

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
PhilipB   
Mon Apr 30 2018, 01:11pm
Member No: #48566
Joined: Jun 05 2017
Location: Barnsley, South Yorkshire
Hello

Last week whilst travelling on the motorway to work I ran over some debris on the motorway whilst changing lanes. It looked like a big strip of metal, something like that and I hit it at about 60mph. It destroyed my tyre on the front drivers side. Anyway I got a new tyre fitted and my alloy checked out which luckily seems fine, not bent or buckled. I've had the balancing checked 3 times because the steering wheel wobbles a bit around 70mph. The ride doesn't feel as smooth as before so I'm wondering if something is amiss. I've had my suspension components checked out when I had my brake discs and pads replaced and the mechanic said everything seems fine. So apart from suspension components, what possible damage could have occurred when I struck the debris?

Thanks
Philip
PhilipB   
Sun May 13 2018, 01:05pm
Member No: #48566
Joined: Jun 05 2017
Location: Barnsley, South Yorkshire
I've been doing some digging and getting help and advice. Although I've been told that everything looks fine, it clearly isn't. I personally think something is bent from the impact. I'm going to take a punt and replace some parts.

I've been advised that the steering arm (same as tie rod, is that right?) could have been damaged as its only a thin piece of metal.

Also tie rod ends can cause symptoms that I'm experiencing.
Suspension arm (same as wishbone?) also.
Control arm, but does the C4 have one because I've only found suspension arms for these cars.

As well as a shaking steering wheel, the steering feels loose and sometimes wanders. Out of these parts which should I prioritise or would be most likely to cause these symptoms?

Any help would be appreciated from you guys on here.

Thanks
Philip
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member