or Login >>         
C4 - DS4 Owners :: Forums :: Coupe and Hatch Pre 2011 cars :: C4 Loeb

2010 Loeb steering pump fail! Part no. Issue help

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
HTRAINo   
Fri Feb 09 2018, 11:41am
Member No: #50456
Joined: Feb 09 2018
Location: UK
Hi everyone! I'm new here, but I've been visiting/reading here for months.
Trying to get my Loeb ready for Hillclimb and the PS pump has gone.

My highly trusted mechanic needs a part no. and Citroën won't dish that information out willy nilly.

Can anyone help at all?
Ham   
Fri Feb 09 2018, 02:42pm

Member No: #69
Joined: Jan 10 2007
Location: Derby, England
I had mine fail ages ago on the VTS due to water getting into the motor. All i did was get one off ebay which cost £20 including P+P (came from a C4 1.6 sx, stripped it cleaned and resealed it. Fitting was a bit awkward as i didnt have a pit to use.
The steering was a bit lighter than the VTS pump, but i think thats probably down to reprogramming(giving more/less assistance) in Lexia which i never had done.
1 User said Thank You to Ham for this Post :
 HTRAINo (10 Feb 2018 : 10:34)
HTRAINo   
Sat Feb 10 2018, 10:38am
Member No: #50456
Joined: Feb 09 2018
Location: UK
Thanks! That should help me out a lot.
1 User said Thank You to HTRAINo for this Post :
 Ham (Last Week)
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member