or Login >>         
C4 - DS4 Owners :: Forums :: C4 Picasso and Grand Picasso - PRE 2013 only :: C4 Picasso Problems and issues

Gap between top of strut tower and top retainer cone

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
Avelar   
Fri Jan 12 2018, 03:29pm
Member No: #43037
Joined: Dec 21 2015
Location: Glasgow
Hi,

At the top of the strut, inside the engine bay(behind the covers) I have a 2-3mm gap between the top retainer cone and the bodywork/strut tower when the car is at rest on the road. It has new springs, spring bearings and mounts and retainer. The nut holding the strut mount to the the spring is fully bottomed out and the top nut is fully torqued. Is this normal? I've read that its normal on VWs and other makes.
rusky   
Sat Jan 13 2018, 03:22am
Member No: #27768
Joined: Oct 13 2012
Location: Hove
Can you post pictures & I'll compare with mine.
1 User said Thank You to rusky for this Post :
 Avelar (15 Jan 2018 : 02:06)
Avelar   
Mon Jan 15 2018, 02:12am
Member No: #43037
Joined: Dec 21 2015
Location: Glasgow
Thanks Rusky I but never had a chance to take a photo. Checked with Citroen dealer he said gap is normal. Looking on forums for VWs etc a gap seems to be normal in modern suspension – apparently if it’s all clamped up tight with no gap the top of the strut is not free to move and the bushes get worn. When I viewed the gap with the steering turning side to side and the car on the floor (not jacked up) I could see the top of the screwed rod and nut moving about freely. Car has now passed MOT.
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member