or Login >>         
C4 - DS4 Owners :: Forums :: Coupe and Hatch Pre 2011 cars :: C4 Coupe and Hatch (pre 2011) Problems?

2008 C4 coupe 1.6 VTi dashboard fault (flashing)

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
highlandwolf   
Fri Jan 20 2017, 05:53am
Member No: #32369
Joined: Sep 03 2013
Location: glasgow
I have a 2008 C4 1.6 VTi petrol. The digital speedo/rev counter has developed a fault in that it intermittently flashes over the whole display. I would like to just replace with a second hand unit. I know there might be issues with the mileage display but I can get that fixed by a mate to the correct mileage. My question is, are these items coded to the car in any way? I lifted it up and the part number is p9664319780. If anyone can help I would be very grateful.
Biohead   
Fri Jan 20 2017, 08:00am

Member No: #6049
Joined: Nov 05 2008
Location: Bracknell
Your best bet is to confirm the correct part number using your Citroen dealer - there are a wide range of models available and you need to make sure you have the correct one. I think the part number is 96 759 325 80.

As it's a VTi, I'm guessing you have a facelift model which means the rev counter is part of the instrument cluster and no longer separate on the steering wheel.

You need to make sure you get that type of instrument cluster, for petrol engines (the diesel has a different rev counter).

If getting a 2nd hand unit, you MUST get a model with a lower mileage as the car will take the highest value and overwrite everything on the car with the highest value. The cluster itself is a whole ECU that speaks to the rest of the car - so bear that in mind.
Ozman49   
Mon Jun 11 2018, 09:37pm
Member No: #42926
Joined: Dec 10 2015
Location: Australia
Hi - I've been searching fro more info on this issue - I have a 2009 C4 Hatch - 1.6 petrol turbo which has the same flashing/flickering multifunction display problem - all the functions are still ok it's just the constant flickering which leads me to think it must be a connector issue - I've wiggled/thumped - tried all the fuses - all to no effect -

Some time ago I tried to pop the display unit out from the dash but it wasn't as easy as it probably should have been and I stopped because I wasn't fully sure how to go about it (tips would be appreciated)

The car has only done 39000 k's so if the odometer logic is contained within the unit (as mentioned above) I'll have trouble with a second hand one unless the mileage can be reset using diagbox

If anyone else has any experience/advice on this in the addition to the above by Biohead, I'd be thankful to hear it

Cheers


 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member