or Login >>         
C4 - DS4 Owners :: Forums :: Coupe and Hatch Pre 2011 cars :: C4 The Garage

Fault codes after EGR cleaning

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
steve233   
Wed Sep 14 2016, 08:15pm
Member No: #45900
Joined: Aug 18 2016
Location: germany
DV6TED4 1.6HDi 2004

Hello, recently I have cleaned my EGR (elektric) on refitting I can't mount the clamp so I unmount the control unit on top, mount the clamp and refit the control unit.
Since then car is stuttering and I have these fault codes stored:
P0490
P1162
Both EGR related, haven't that problems before.
I want to be sure EGR is not clogged, I remove and clean it.

Have I overlooked something at refitting?
AndrewM   
Wed Sep 14 2016, 11:03pm
Member No: #34563
Joined: Mar 04 2014
Location: Swansea UK
Hello Steve

When I had EGR issues, I removed the EGR and replaced it with a new one. I did dismantle the old one to see if it could be cleaned and used as a spare but it did seem to be difficult to get it back together properly. I think it has to be done very carefully.

It sounds as though yours isn't correctly aligned inside. If it was me, I would have put a new one on as they can be bought for around £100 on the auction site (genuine part).

It is fiddly to get the clamp back on put I believe you shouldn't really dismantle the top part.

After I fitted my new EGR it resolved my stuttering issues and has been good for the last year.
Markta   
Sat Feb 10 2018, 05:40pm
Member No: #49278
Joined: Aug 28 2017
Location: GREAT YARMOUTH
Sorry to hijack but note that this thread hasn’t been replied to for over a year.

Seems like I have intermittent turbo lag on my 2007 C4 1.6 HDI DVR engine when I try and pull away from idle. Hardly ever happens but when it does it suddenly surges.

I have used my Sykes Pickavant ACR4 code reader and I get p0409 and 0490.

Knackered EGR valve?

Thanks
gazax   
Sun Feb 11 2018, 03:37am
Member No: #50107
Joined: Dec 24 2017
Location: Royston, Barnsley
It most certainly seems like it. It will only get worse so either try cleaning it with brake/carb cleaner or replace. Don't do what I did and buy a cheap one of ebay, that broke after about 6/7 months. Get one from Euro car parts, always have a good deal on over the weekends
1 User said Thank You to gazax for this Post :
 Markta (11 Feb 2018 : 04:39)
Markta   
Sun Feb 11 2018, 04:42am
Member No: #49278
Joined: Aug 28 2017
Location: GREAT YARMOUTH
gazax wrote ...

It most certainly seems like it. It will only get worse so either try cleaning it with brake/carb cleaner or replace. Don't do what I did and buy a cheap one of ebay, that broke after about 6/7 months. Get one from Euro car parts, always have a good deal on over the weekends


Thanks. I will order one through Mister Auto (Valeo), about £60 cheaper than ECP.

I have Lexia 3 to code the new EGR to ECU
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member