or Login >>         
C4 - DS4 Owners :: Forums :: Citroen C4 Picasso and Grand C4 Picasso (B78) 2013 onward :: C4 Picasso and Grand C4 Picasso (B78) Problems and Issues

Airbag warning light fault - 2014 Grand C4 Picasso

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
kyojitsu   
Fri Apr 17 2015, 05:44am
Member No: #40171
Joined: Apr 17 2015
Location: Leicester
I've managed to resolve this fault via a warranty repair at the dealer but it's here for anyone else who might get the same issue crop up. We had intermittent appearances of a warning message saying "Airbag or seatbelt pretensioner fault" accompanied by a permanent yellow airbag symbol in the top right of the upper screen. This would then disappear on the next few startups only to appear again randomly. Of course this wouldn't ever happen when I was at the dealer so I resorted to a video to prove I wasn't insane! Anyway - it turned out this was a wiring harness fault (known by Citroen) and I believe it gets snagged under one of the seats and triggers a fault. Got replaced and now it's fine.
1 User said Thank You to kyojitsu for this Post :
 jsg1163 (24 Jun 2019 : 05:29)
routemaster1   
Fri Apr 17 2015, 05:56am
Member No: #574
Joined: Jul 08 2007
Location: Dorset
kyojitsu wrote ...

I've managed to resolve this fault via a warranty repair at the dealer but it's here for anyone else who might get the same issue crop up. We had intermittent appearances of a warning message saying "Airbag or seatbelt pretensioner fault" accompanied by a permanent yellow airbag symbol in the top right of the upper screen. This would then disappear on the next few startups only to appear again randomly. Of course this wouldn't ever happen when I was at the dealer so I resorted to a video to prove I wasn't insane! Anyway - it turned out this was a wiring harness fault (known by Citroen) and I believe it gets snagged under one of the seats and triggers a fault. Got replaced and now it's fine.

This type of fault is common. I first had this on a Clio a few years ago, and it turned out to be due to my daughter's shoe collection under the seat. So if anyone else has this, clear the area and check the connectors.
1 User said Thank You to routemaster1 for this Post :
 kyojitsu (02 May 2015 : 09:46)
Itchigo27   
Sat Jun 22 2019, 07:25am
Member No: #52604
Joined: Nov 29 2018
Location: Middlesex
Do you know the error code this fault had? I've got the same problem!
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, Forum Moderator, Forum Moderator, Premier Member, Technical Expert, New C4 and DS4 Forum Moderators, Member